• July 31, 2021, 12:40:37 AM

Login with username, password and session length

NOTE: This forum is for respectful dialog and it's content is meant to be kept on this site - so please be respectful and please do not copy content to other sites.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - philw

Pages: [1]
1
MMR Support [MMR Members Only] / Castle Gate Stuck Closed
« on: February 27, 2020, 11:41:45 AM »

My machine started with this self-test error today. The "gate" (portcullis) won't rise. When it is supposed to rise, it does make the "thud" which sounds like a solenoid firing.

I pushed all the connexions on their seatings as per other posts here and they seemed ok and that made no difference.
I suppose there's something mechanical which is broken in here.


The manual (pages 1-25/1-26) is not entirely clear on this, but the two switches M.EN and C.GT are working correctly, but the test fails presumably because the portcullis doesn't actually rise.


The very satisfying "thud" suggests it's a mechanical problem, but I can't find an obvious diagram for this.
Any ideas please? Not getting into the castle's going to really drop the extra-ball required-score of course... ;-)

2
My left troll doesn't work, and the start up self-test reports as per the title.


If I follow this thread: [size=78%]You are not allowed to view links. Register or Login[/size]


I can get into "tests" "switch edges". When I flip either the left or the right troll's up-detection micro switch, it works as expected, flashing the on-screen display with the correct switch name etc.


Has anyone any idea what this is - I can't get the trolls if they don't both come up :-(

3
MMR Support [MMR Members Only] / Castle not rebuilding correctly
« on: June 15, 2018, 03:30:39 AM »
After 5,603 games my castle has broken.


Symptoms:
  • it doesn't "rebuild", it's in the "damaged" state all the time (see image)
  • the machine makes the usual "castle is breaking" noises, but nothing much happens when the castle's supposed to "vibrate".
  • I took the cover off and found a black plastic bracket which appears loose inside the castle
Looking at the manual I can't quite work out where that bracket comes from, but from the location it was found in plus the shape of the break it looks like it should sit at the bottom of the castle. From the manual page 2-25 Exploding Castle Assembly it looks like:
  • item number 1, part 04-10879.2 Bracket Castle
  • Could anyone point out where I can buy those brackets?
    UK dealer support has been... not great in the past, but I have a US bank account so just buying stuff direct from there is easiest although I'm in Europe.
  • I could presumably super glue the bracket as a temporary repair whilst I try to source the part?
  • Is there any reason I should not continue to use the machine even with the castle broken?
  • Does anyone have any idea how to start disassembling the castle? There are four obvious slot-headed bolts around the black metal base (can't find a diagram for this)... probably taking those out will allow the whole assembly to be removed, then I can likely work out how to get to the base of the main tower.


4
MMR Support [MMR Members Only] / Troll refuses to drop
« on: February 02, 2017, 05:10:04 PM »

I have a couple of issues with this machine, which is a few months old.


  • It's refusing to save time and date - I guess that's the backup battery which is dead.
  • As below, one of the trolls is refusing to drop back into the playfield.
I guess I can sort (1) by either getting my distributor to come and fix it, or getting them to send me a battery and replacing it myself.


(2) looks more problematic.
  • I tried manipulating it manually and it won't have it.
  • I tried the test menu but that doesn't seem to do anything to either troll.
  • If I take the ball out of the playfield and then let the 10-second timer run, the left troll pops up and down as you'd expect. The right one didn't move.
    I *think* the right one made some noise but I can't be sure.
    The troll face looks like it's not pointing quite in the right direction - he's looking leftwards.
Any suggestions please? It is under guarantee but it's going to be expensive and I suppose slow if they have to come and fix it.






Pages: [1]