• February 23, 2024, 03:16:23 AM

Login with username, password and session length

NOTE: This forum is for respectful dialog and it's content is meant to be kept on this site - so please be respectful and please do not copy content to other sites.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - MrRich

Pages: [1]
1
MMR Support [MMR Members Only] / Time and Date Circuit
« on: August 23, 2017, 04:41:38 PM »
It seems like the time and date function on MMR Controller Board has had issues for some time.  My machine is no different.  Software updates have helped reduced the frequency of time and date errors, but not eliminated them on my machine.  Since they don’t stop me from enjoying my game, I try to ignore them, but I wish they could be stopped forever.

Being a Senior Electrical Engineer, I understand that intermittent errors are the hardest types to troubleshoot and resolve.  Sometimes having another set of eyes look at the problem will help (outside the design team).  So, I had a few free minutes and decided to review the time and date circuit.  It’s very simple design from a parts count point of view.  However, the main component (a Real Time Clock IC P/N PCF8523) is far from simple…the date sheet is 78 pages.

After reading the data sheet, I came across one requirement that could be a problem.  When the machine power is turned off, the chip will automatically switch power from board 3.3V to a 3V coin battery.  However, the rate at which the board 3.3V drops to the 3V coin battery is very important for reliable operation.  It must be lower than 0.7 V/ms.

To meet this requirement, a resistor (R28) and capacitor (CP2) configuration are used between the board 3.3V and the power pin on the chip.  Where I think a problem exists is the capacitor value for CP2.  The data sheet recommends a value of 3.3 uF to “assure the proper functionality of the battery switch-over”.  What’s install is a 0.1 uF.

Is 0.1 uF enough?  The answer is maybe.  You would have to know how the power decays on the board and simulate it over the tolerance ranges of every component (so it works on all boards).  Not a quick and simple task.  Proving it works is a lot more effort than using the recommended or higher capacitance value.  I hope CGC will verify the CP2 is the correct value they wanted.

2
MMR Support [MMR Members Only] / Re: Translite/Speaker Panel fitment
« on: March 08, 2016, 01:54:57 PM »
I had the same problem removing my translite.  Thought I was going to break something every time it was removed and re-installed.  After measuring, inspecting, and trying other translite assemblies (TOTAN and MB), I came to the conclusion that the problem was the plastic white insert behind the glass.  Looks like CGC redesigned this piece for LED strips and didn't leave enough clearance on the top.  The main clue for me was a black line on top of the white insert where it was hitting the internal wood guide and rubbing off black paint.  I had to put a lot of upward pressure to get it out.  There's nothing wrong with the glass size or plastic trim pieces or the speaker panel or the back box cabinet size.  I spent hours measuring this stuff.

This bugged me sooo much that I decided to fix it myself.  I waited until my family was out for a couple of hours (wife would of had me committed if she knew what I was about to do) and removed the back box from the machine.  Next, I removed speaker panel and turned the back box upside down.  Using a sanding block with 120 grit paper, I sanded the edge of internal wood guide to match the angle of the insert.  I only need about an 1/16" of additional clearance.  After sanding for a few minutes, I cleaned up the dust, turned the back box right side up, re-installed the speaker panel and tested the translite fit.  First try was much better, but still needed a little more clearance.  After repeating the sanding sequence 1 more time, I was very happy with fit.  To hide any evidence of my modification, I painted the area I sanded with semi gloss black paint pen.  The whole process took a little over an hour, but I was being very careful with everything.  A little novus on a rag cleaned up the black line on the insert.

I'm not sure how CGC would have resolved this.  In their defense, I didn't give them a chance.  Do you have the same issue?  Try this...remove the plastic white insert from your translite assembly (keep your trim pieces on).  If you can freely remove/install your glass, the problem is with your white insert.  If not, you have a different problem.

Pages: [1]