• April 13, 2024, 12:21:13 AM

Login with username, password and session length

NOTE: This forum is for respectful dialog and it's content is meant to be kept on this site - so please be respectful and please do not copy content to other sites.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - philw

Pages: 1 [2]
16
MMR Support [MMR Members Only] / Re: Castle not rebuilding correctly
« on: June 15, 2018, 03:07:41 PM »
I see those... I will have a shot at that and see if it sorts it. Thanks!

17
MMR Support [MMR Members Only] / Re: Castle not rebuilding correctly
« on: June 15, 2018, 07:21:15 AM »
Right, that's fixed, with epoxy.
I glued it back on, put it all back, and it's working perfectly.

Next up:
  • I have 2.01 so I need to upgrade that to 2.02 as I have the "date time" issue.
  • I'm getting balls stuck behind the right hand troll now and then - anyone know how to stop/ fix that?

    Problem solved though!

18
MMR Support [MMR Members Only] / Re: Castle not rebuilding correctly
« on: June 15, 2018, 04:36:26 AM »
Ah, it was the four slotted hex-head bolts, one of which was pretty tight to get out. Maybe I should use some removable Locktite on them when they go back in.

Here's the assembly removed, which is that on page 2-25. The removed rod and holds the main tower to the metal base. Taking one circlip off is sufficient to allow wiggling the rod out of there and releasing the main tower.

The main turret has a grey base plate stuck to the bottom of the actual tower. That base plate is "poked" by a rod from beneath when the castle is "breaking". Hence the base plate has a load point where it meets the main tower... which is where it fractured in my case.

I will try to epoxy the base back onto the tower. Maybe that will hold. If it doesn't I could probably "beef up" the base by adding something under the plastic to strengthen it (carbon fibre comes to mind). If that doesn't work then I'll need the replacement part, which I suspect is both base plate and castle combined.

19
MMR Support [MMR Members Only] / Castle not rebuilding correctly
« on: June 15, 2018, 03:30:39 AM »
After 5,603 games my castle has broken.


Symptoms:
  • it doesn't "rebuild", it's in the "damaged" state all the time (see image)
  • the machine makes the usual "castle is breaking" noises, but nothing much happens when the castle's supposed to "vibrate".
  • I took the cover off and found a black plastic bracket which appears loose inside the castle
Looking at the manual I can't quite work out where that bracket comes from, but from the location it was found in plus the shape of the break it looks like it should sit at the bottom of the castle. From the manual page 2-25 Exploding Castle Assembly it looks like:
  • item number 1, part 04-10879.2 Bracket Castle
  • Could anyone point out where I can buy those brackets?
    UK dealer support has been... not great in the past, but I have a US bank account so just buying stuff direct from there is easiest although I'm in Europe.
  • I could presumably super glue the bracket as a temporary repair whilst I try to source the part?
  • Is there any reason I should not continue to use the machine even with the castle broken?
  • Does anyone have any idea how to start disassembling the castle? There are four obvious slot-headed bolts around the black metal base (can't find a diagram for this)... probably taking those out will allow the whole assembly to be removed, then I can likely work out how to get to the base of the main tower.


20
MMR Support [MMR Members Only] / Re: Troll refuses to drop
« on: February 05, 2017, 04:43:13 AM »
I can't get bolts in those units, so the dealer will need to send me a set.
Meanwhile I lashed it up with a smaller bolt plus washers and a nut, which gets me going.


I used (removable) threadlock on both bolts, so they should not come out again unless I take them out.
I looked at the other side, but both bolts there look ok so I didn't touch them.

Thanks!

-- --
Whilst I was in there I updated the firmware to the latest 2.0.1 from the original 1.something. That seems to have cured the "lost date and time" issue.

21
MMR Support [MMR Members Only] / Re: Troll refuses to drop
« on: February 03, 2017, 04:33:14 PM »
Got it - thanks. Plus as these are actually bolts (not screws), I managed to get the sheared one out from the front, if you see what I mean. So now all I need is to source some replacement bolts. And then check the other side, and perhaps use some blue thread-lock on them as I put them back.

I will try to source some locally, although we're all metric here. If that doesn't work I'll get them from the dealer.


thanks for your help... it should be plain sailing from here, I'll post an image of the machine when I get it working again!

22
MMR Support [MMR Members Only] / Re: Troll refuses to drop
« on: February 03, 2017, 06:06:15 AM »
Thanks - I'll source those from somewhere or ask the distributor for some (our stuff is metric).

Getting the screw out looks problematic, it's tiny. The machine under warranty here (EU law, yay!) so I may need to return it to the supplier if I can't work it out.

Any advice on how to get to where the screws need to go in? I guess I have to undo that bolt and then I can get "around the back" where the screws go in. Otherwise access to them is blocked.



23
MMR Support [MMR Members Only] / Re: Troll refuses to drop
« on: February 02, 2017, 06:03:37 PM »
Excellent - thanks for the support.... before i read it, I took the whole assembly out - I didn't see the black bolt there, but I see it now. We could see one of the screws was loose - not in the hole properly, but then...


As per this image, the second screw had sheared off!


I can get replacement screws I suppose - they don't look too odd. If you know the measurements that may help, or the distributor may have some.


But I need to get that sheared off screw out of that hole somehow. There's nothing at the head end to grip, although it sticks out a fraction at the pointy end. Ideas? I suppose if I can find a shop someone may have an extractor for things like that? But then why did these break in the first place: is the whole assembly ok?


I guess I should check the other one. Both trolls were quite hard to shoot - you had to hit them pretty hard to score.

Any ideas?

thanks again. I'm getting there

24
MMR Support [MMR Members Only] / Re: Troll refuses to drop
« on: February 02, 2017, 05:22:49 PM »
The microswitches look fine on both, but the one on the broken troll is no where near the assembly. The issue is that the right hand (player's right) troll won't descend because he does not appear to fit down his hole. Something physical is stopping him descending.


See attached shot of the two solenoids, neither of which has power in this shot. Note that the right-hand one is under spring and gravity tension but it's not coming down. You can see also in the shot that the right hand troll face is displaced.


I would guess that the top part of the assembly, where the troll face appears displaced, is somehow obstructing the descent of the troll. So I think the electrics are likely all fine, but there's a physical obstruction there.


Anyone any ideas on this please? If I can work out how to disassemble the troll head maybe I can get the thing to drop.

25
MMR Support [MMR Members Only] / Troll refuses to drop
« on: February 02, 2017, 05:10:04 PM »

I have a couple of issues with this machine, which is a few months old.


  • It's refusing to save time and date - I guess that's the backup battery which is dead.
  • As below, one of the trolls is refusing to drop back into the playfield.
I guess I can sort (1) by either getting my distributor to come and fix it, or getting them to send me a battery and replacing it myself.


(2) looks more problematic.
  • I tried manipulating it manually and it won't have it.
  • I tried the test menu but that doesn't seem to do anything to either troll.
  • If I take the ball out of the playfield and then let the 10-second timer run, the left troll pops up and down as you'd expect. The right one didn't move.
    I *think* the right one made some noise but I can't be sure.
    The troll face looks like it's not pointing quite in the right direction - he's looking leftwards.
Any suggestions please? It is under guarantee but it's going to be expensive and I suppose slow if they have to come and fix it.






Pages: 1 [2]