• February 23, 2024, 01:19:02 AM

Login with username, password and session length

NOTE: This forum is for respectful dialog and it's content is meant to be kept on this site - so please be respectful and please do not copy content to other sites.

Author Topic: LED DISPLAY GOES OUT IN 30 seconds  (Read 7278 times)

Offline mkistner

  • PPS Forum Member
  • One Star Member
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
LED DISPLAY GOES OUT IN 30 seconds
« on: May 09, 2015, 01:36:13 PM »
hi


I just received my MMR and we have two issues. The LED display works for 30 seconds and then stops working. We have reset the machine and every time the LED turns on for 30 seconds than goes blank. I also never received my registration card. Please help as we can't see anything on the screen!!!

Offline Lloyd Olson

  • LTG : )
  • Global Moderator
  • Three Star Member
  • *****
  • Posts: 385
  • Karma: +18/-7
    • View Profile
Re: LED DISPLAY GOES OUT IN 30 seconds
« Reply #1 on: May 09, 2015, 08:40:58 PM »
Registration card here :

You are not allowed to view links. Register or Login

LCD - please go over power connectors at LEC and where they go to, be sure they are on tight. Reseat the HDMI connector on top of the small board in the head.

From your description it sounds like something is loose.

LTG : )

Offline 1PinballKnight

  • PPS Forum Member
  • Two Star Member
  • *
  • Posts: 73
  • Karma: +0/-0
    • View Profile
Re: LED DISPLAY GOES OUT IN 30 seconds
« Reply #2 on: May 10, 2015, 03:19:55 PM »
Lloyd, I've been in Electronics for 35 years, the LCD coming on for 30 sec is a connection but goes out. Something electronic could be failing but I agree to check all connectors just to be sure.  If it is happening all the time makes me wonder wether the display or something feedin it, R

Offline Jaimerscherr

  • PPS Forum Member
  • One Star Member
  • *
  • Posts: 19
  • Karma: +0/-0
    • View Profile
Re: LED DISPLAY GOES OUT IN 30 seconds
« Reply #3 on: August 04, 2015, 09:56:38 PM »
My mmrle first time same issue turn off on off on off on sometimes works sometimes not sometimes boots with display sometimes not please help I paid a ton of money for this 1st day I got issues

Offline Lloyd Olson

  • LTG : )
  • Global Moderator
  • Three Star Member
  • *****
  • Posts: 385
  • Karma: +18/-7
    • View Profile
Re: LED DISPLAY GOES OUT IN 30 seconds
« Reply #4 on: August 05, 2015, 12:32:25 AM »
As Rick posted in the other thread, please open a ticket.

Most likely something came loose in shipping. Please check the connectors in the head to the small board, be sure they are all on tight.

I am sorry you have an issue. CGC will get you through it.
LTG : )